Web Agent connection error with OpenAM And Apache Haus

This topic contains 1 voice and has 0 replies.

  • Author
    Posts
  • #26533
     harshateja 
    Participant

    Hi All,

    I am Harsha Teja, learning ForgeRock to add it to my skill set. I was able to configure OpenAM in Tomcat Apache Server. I have a Apache Haus Server hosting a web page. I want to understand how the web agent works. I have been successful in creating a Web Agent profile in OpenAM and installed webagent compatible with Apache24 server. After this step, I am unable to start the Apache Haus Server.

    The Following error is being displayed on trying to start the server:

    Error: “httpd: Syntax error on line 535 of C:/Apache24/conf/httpd.conf: Cannot load C:\\apache24_agent\\bin\\..\\lib\\mod_openam.dll into server: %1 is not a valid Win32 application.

    The lines of Httpd.Config file are :

    Line 535: LoadModule amagent_module C:\apache24_agent\bin\..\lib\mod_openam.dll
    Line 536: AmAgent On
    Line 537: AmAgentConf C:\apache24_agent\bin\..\instances\agent_2\config\agent.conf

    I am stuck in this step from almost a week.
    Please help in understanding the error and assist me in moving forward with my learning.

    Thanks & Regards,
    Harsha Teja G

    • This topic was modified 2 weeks, 6 days ago by  Peter Major.
Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

©2019 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?