Web Agent 4.1 on IIS – invalid password

This topic has 0 replies, 1 voice, and was last updated 2 years, 11 months ago by rokitsalad.

  • Author
    Posts
  • #23849
     rokitsalad
    Participant

    I’ve been trying for over a day to get the web agent to install into my local IIS. When I try to install, I get the following into the logs:

    2018-11-15 09:18:33 OpenAM Web Agent for IIS server silent installation
    2018-11-15 09:18:33 license was accepted earlier
    2018-11-15 09:18:33 validating configuration parameters…
    2018-11-15 09:18:33 send_authcontext_request(): sending 489 bytes to https://hidden:8443/openam/authservice
    2018-11-15 09:18:33 send_authcontext_request(): response status code: 200
    <?xml version=”1.0″ encoding=”UTF-8″ standalone=”yes”?>
    <ResponseSet vers=”1.0″ svcid=”auth” reqid=”0″>
    <Response><![CDATA[<?xml version=”1.0″ encoding=”UTF-8″?>
    <AuthContext version=”1.0″><Response authIdentifier=”AQIC5wM2LY4Sfcx2jnDqCxLgcZlXh5vtCD3rjwd4r4bzcLY.*AAJTSQACMDEAAlNLABQtMzg5NTUzMTIwNDA4NzU0Njc4OAACUzEAAA..*”><LoginStatus status=”in_progress”></LoginStatus></Response></AuthContext>]]></Response>
    </ResponseSet>
    2018-11-15 09:18:33 create_cookie_header(): request header: Cookie: JSESSIONID=kx-MOy30n41x17FFHnWtSp5s; amlbcookie=01

    2018-11-15 09:18:33 send_login_request(): sending 1201 bytes to https://hidden:8443/openam/authservice
    2018-11-15 09:18:34 send_login_request(): authenticate response status code: 200
    <?xml version=”1.0″ encoding=”UTF-8″ standalone=”yes”?>
    <ResponseSet vers=”1.0″ svcid=”auth” reqid=”0″>
    <Response><![CDATA[<?xml version=”1.0″ encoding=”UTF-8″?>
    <AuthContext version=”1.0″><Response authIdentifier=”AQIC5wM2LY4Sfcx2jnDqCxLgcZlXh5vtCD3rjwd4r4bzcLY.*AAJTSQACMDEAAlNLABQtMzg5NTUzMTIwNDA4NzU0Njc4OAACUzEAAA..*”><GetRequirements><Callbacks length=”2″><NameCallback><Prompt>Enter application name.</Prompt></NameCallback><PasswordCallback echoPassword=”true”><Prompt>Enter secret string.</Prompt></PasswordCallback></Callbacks></GetRequirements></Response></AuthContext>]]></Response>
    <Response><![CDATA[<?xml version=”1.0″ encoding=”UTF-8″?>
    <AuthContext version=”1.0″><Response authIdentifier=”AQIC5wM2LY4Sfcx2jnDqCxLgcZlXh5vtCD3rjwd4r4bzcLY.*AAJTSQACMDEAAlNLABQtMzg5NTUzMTIwNDA4NzU0Njc4OAACUzEAAA..*”><LoginStatus status=”failed”></LoginStatus><Exception message=”invalid password” errorCode=”107″ templateName=”login_failed_template.jsp”></Exception></Response></AuthContext>]]></Response>
    </ResponseSet>
    2018-11-15 09:18:34 am_agent_login(): closing connection after failure
    2018-11-15 09:18:34 error validating OpenAM agent configuration
    2018-11-15 09:18:34 installation error
    2018-11-15 09:18:34 installation exit

    I’ve tried recreating the agent config in AM, using different complexities of password, removing the carriage return from the password file created with echo, setting the password file as readonly, removing all permissions from the password file but read permissions for my user, and probably a few other things I can’t think of right now.

    I’m stumbling at the first hurdle – can anyone suggest what I might be doing wrong?

    TIA, Pete.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

©2021 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?