This topic has 4 replies, 3 voices, and was last updated 5 years, 6 months ago by alvin.

  • Author
    Posts
  • #16107
     alvin
    Participant

    I use the Mysql to change orientDB,then ‘./startup.sh’,find the process of ‘org.forgerock.openidm.repo.orientdb’ still running.why??

    #16108
     laurent.bristiel
    Participant

    I don’t think “org.forgerock.openidm.repo.orientdb” is really a process.
    How did you come to the conclusion that it was a running process?
    Are you looking at the list of bundle/services within the OSGI console?
    If so you might see orientdb in the list but it should not be active.

    #16110
     alvin
    Participant

    thanks ,however ,the statu of “org.forgerock.openidm.repo.orientdb” is ‘active’

    #16113
     Bill Nelson
    Participant

    @alvin, you need to remove the repo.orientdb.json file from the openidm/conf folder and replace it with the repo.jdbc.json (and associated datasource.jdbc-default.json file). This will effectively replace the OrientDB repo with your MySQL one.

    If you don’t want to see the OrientDB database show up any longer in your services list, you would need to remove the bundle/openidm-repo-orientdb-4.0.0.jar file as well. Just make sure you do this with OpenIDM and remove your felix-cache before restarting.

    #16215
     alvin
    Participant

    thanks,I access the’http://localhost/system/console’,set the statu of ‘repo.orientdb’ to ‘disable’,then restart openidm.haha,I see the problem solved

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

©2022 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?