Unable to start openam application after deployment on Apache tomcat

This topic has 4 replies, 3 voices, and was last updated 2 years, 2 months ago by karthik0001.

  • Author
    Posts
  • #21892
     aanandsri
    Participant

    Hi,

    I have deployed openam 6.0 on tomcat 9.0.1. When I am trying to start the services for openam configuration it is throwing below error –

    =========

    21-May-2018 16:52:50.327 SEVERE [main] org.apache.catalina.core.ContainerBase.addChildInternal ContainerBase.addChild: start:
    org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/accessmanager]]
    at org.apache.catalina.util.LifecycleBase.handleSubClassException(LifecycleBase.java:441)
    at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:198)
    at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:740
    ========

    21-May-2018 16:52:50.333 SEVERE [main] org.apache.catalina.startup.HostConfig.deployWAR Error deploying web application archive [C:\Program Files\Apache Software Foundation\Tomcat 9.0\webapps\accessmanager.war]
    java.lang.IllegalStateException: ContainerBase.addChild: start: org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/accessmanager]]
    at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:744)
    at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:716)
    at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:703)
    at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:978)
    at org.apache.catalina.startup.HostConfig$DeployWar.run(HostConfig.java:1850)
    at java.base/java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:514)
    at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
    at org.apache.tomcat.util.threads.InlineExecutorService.execute(InlineExecutorService.java:75)
    at java.base/java.util.concurrent.AbstractExecutorService.submit(AbstractExecutorService.java:118)
    at org.apache.catalina.startup.HostConfig.deployWARs(HostConfig.java:762)
    at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:431)

    Please, could you advise if anyone faced same error?

    • This topic was modified 2 years, 2 months ago by Peter Major.
    #21896
     srinath.m
    Participant

    Hi Aanandsri,
    I have tried the same configuration in my local system and it works fine without any errors. I did below things to install AM-6.0.0 on Tomcat 9
    1.Removed AM5.5.1.war and AM5.5.1 folder from tomcat webapps folder.
    2.Removed the .openamcfg files from “C:\Windows\System32\config\systemprofile” location.
    3.Deployed AM-6.0.0 on tomcat webapps folder and started the tomcat, can see the openam Configuration Options page.

    Hope it may helps to you.
    Thanks,
    Srinath

    #21897
     aanandsri
    Participant

    Hi Srinath,

    Thanks for the response. I will look into your suggestion.
    For the time being, I down-grade my tomcat from 9.0.1 to 8.5.31 and it works!

    Thanks
    Ashish S

    #22197
     karthik0001
    Participant

    Hi Ashish S,

    I got a similar error when I used tomcat 9.0.8 and AM 6.
    I added a setenv.sh file in /bin directory and exported the java 8 path and it did fix the error for me.

    Error

    27-May-2018 02:40:43.921 SEVERE [main] org.apache.catalina.core.ContainerBase.addChildInternal ContainerBase.addC
    hild: start:
     org.apache.catalina.LifecycleException: Failed to start component [StandardEngine[Catalina].StandardHost[localho
    st].StandardContext[/openam]]
            at org.apache.catalina.util.LifecycleBase.handleSubClassException(LifecycleBase.java:441)
            at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:198)



    27-May-2018 02:40:43.930 SEVERE [main] org.apache.catalina.startup.HostConfig.deployWAR Error deploying web appli
    cation archive [/usr/local/apache-tomcat-9.0.8/webapps/openam.war]
     java.lang.IllegalStateException: ContainerBase.addChild: start: org.apache.catalina.LifecycleException: Failed t
    o start component [StandardEngine[Catalina].StandardHost[localhost].StandardContext[/openam]]
            at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:746)
            at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:718)
            at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:703)

    My Fix was
    Added a setenv.sh file in $TOMCAT/bin

    JAVA_HOME=/usr/lib/jvm/java-8-oracle
    CATALINA_OPS="-server -Xmx2g -XX:MetaspaceSize=256m -XX:MaxMetaspaceSize=256m"
    #22198
     karthik0001
    Participant

    I had multiple java version installed but got correct java version in the tomcat-users bash profile and still got that error.
    So I exported java path from setenv.sh and it worked for me.
    Also, be sure to do chmod +x setenv.sh

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

©2020 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?