Unable to Configure Social AuthN in ForgeRock IDM

This topic has 0 replies, 1 voice, and was last updated 2 years, 10 months ago by rasarkar.

  • Author
    Posts
  • #24030
     rasarkar
    Participant

    Hello Guys,

    I have been trying to configure social authentication with Google on my local and facing some strange issues-

    With IDM 6.0 the authentication with google is fine. But after it redirects to OpenIDM one POST request to the URL https://idm.example.com/openidm/identityProviders?_action=handlePostAuth fails with the following error-

    {“code”:400,”reason”:”Bad Request”,”message”:”Could not handle post auth request.”,”detail”:{“landingPage”:”https://idm.example.com/#login/&oauthReturn=true&provider=google&gotoURL=%23″,”providerException”:”Cannot find resolver for issuer https://accounts.google.com”}}

    with IDM 6.5 the same request fails with a different error-

    {“code”:400,”reason”:”Bad Request”,”message”:”Could not handle post auth request.”,”detail”:{“landingPage”:”http:/idm.example.com:8080/#/login?_oauthReturn=true&provider=google&gotoURL=%23″,”providerException”:”javax.net.ssl.SSLHandshakeException: General SSLEngine problem”}}

    If anyone has any insight that would be really helpful. Please help. The issue is same in case of authentication as well as registration.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

©2021 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?