Unable to Configure Google Social Authentication

Tagged: ,

This topic has 4 replies, 4 voices, and was last updated 2 years, 7 months ago by Henri.C.Lefevre.

  • Author
    Posts
  • #19713
     rasarkar
    Participant

    Hi Team,

    I am trying to configure social authentication in OpenAM using google. After entering client ID and client secret I see the following error- “Unable to reach, https://accounts.google.com/.well-known/openid-configuration.”

    Anybody has any idea how to fix it?

    Regards
    Ranajoy

    #23959
     datta
    Participant

    Hi @rasarkar,
    I am facing the same problem which you are facing in the Social Authentication.
    Did you get the solution to your problem?

    Thanks,
    Dattatray Deshmukh

    #23963
     Peter Major
    Moderator

    Works fine for me, do you see anything in the debug logs?
    Keep in mind that when you use the social authentication wizard, AM will try to make an HTTP GET request to the above mentioned well-known endpoint to figure out what endpoints/config to use for the authentication module.

    #24029
     rasarkar
    Participant

    If you are configuring it in VM, make sure you have connectivity to internet. That was the reason for me. There is also a chance of an SSL issue. So try to import the google certificates in your java keystore

    #24910
     Henri.C.Lefevre
    Participant

    Hi, I am facing the same issue, do you know where I can find Google certificates ?

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

©2021 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?