Unable to clone repository

This topic has 6 replies, 4 voices, and was last updated 6 years, 8 months ago by b.lavit.

  • Author
    Posts
  • #5887

    Hello there,

    First of all, my environment is:
    · Windows 7 32bit.
    · Cygwin
    · Git version 2.5.1
    · $ ssh -V OpenSSH_7.1p1, OpenSSL 1.0.2d 9 Jul 2015

    Following the steps described in “https://forgerock.org/projects/getting-the-source-code/” I have created an account at “stash.forgerock.org”, activated it (emailed link) and included my public key within my account. However I am getting this when trying to clone the OpenAM repository:

    [email protected] ~
    $ git clone ssh://[email protected]:7999/openam/openam.git
    Cloning into 'openam'...
    Enter passphrase for key '/home/John/.ssh/id_rsa':
    fatal: remote error: Repository does not exist
    The requested repository does not exist, or you do not have permission to
    access it.
    

    Not sure if PK pair is RSA1 or RSA2 nor could I assure the length of them, if this could be an issue I can try generating a pair with the required version and length, but it sounds to me much more than an issue with the account activation, as I cannot even browse any project or repository after logging in at https://stash.forgerock.org/.

    Any help will be much appreciated!!!

    Thank you for your attention in advance.

    #5922
     Mike Jang
    Spectator

    Hi,

    One different approach — log into https://stash.forgerock.org/ and navigate to https://stash.forgerock.org/projects/OPENAM/repos/openam/browse

    In the upper left part of the page, click on the ellipsis (…), and click clone in the menu that appears. As shown, you’ll get a chance to use software known as SourceTree to clone the OpenAM repo.

    I haven’t tried SourceTree in Windows, but I use it in Mac to clone our repos internally.

    Do let us know if it helps. We might want to revise our instructions.

    Thanks,
    Mike

    #5923

    Hello Mike,

    I tried a while after posting the issue and the repo was cloned uneventfully… Same console, same command, same Windows session, and it just worked. Similarly, after logging in in Stash, the projects appeared where I previously could see nothing. So I believe it is was just a matter of the account not being activated inmediately. I am not sure about this, of course, I am guessing.

    Regarding your instructions I think they are fine, I would only add a warning, in case somebody else reports the same issue than me, saying that the account might take some time to get effectively active. Nevertheless, I read in your forums you are migrating the code to Stash, so it might well be I tried to clone during some mainteinance window… Don’t know, just providing info for you to consider it.

    Thank you for the detailed response and the alternative method you provided!!!

    Regards.

    Francisco

    #5947
     Mike Jang
    Spectator

    Hi Francisco,

    Thanks for the tips, and we appreciate the feedback.

    Thanks,
    Mike

    #6703
     hahmadi
    Participant

    Hi Mike,

    For some reason, I cannot authenticate to stash.forgerock.org, while (same company user-password) account let me login to backstage.forgerock.com. Do you know whom should I discuss this matter with?

    Thanks,
    Hadi

    #6710
     b.lavit
    Participant

    Hi Hadi,

    I’ve checked your Stash profile and you are in the relevant LDAP groups (all-users-virtual, customers, partners, …).

    Can you send me your error message?

    Thanks,
    Bruno (release engineer at ForgeRock)

    #6719
     b.lavit
    Participant

    A quick update on Hadi’s problem.

    He was using the wrong user_id (his email) instead of his Backstage account (hahmadi).

    Stash is using the same users directory than Backstage.

    Thanks,
    Bruno

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

©2022 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?