Two openam webapps installed on the same machine

This topic has 8 replies, 6 voices, and was last updated 5 years, 10 months ago by nikolaosinlight.

  • Author
    Posts
  • #3754
     support_ss
    Participant

    Hi,
    we are using OpenAM 11.0.0 with Apache Tomcat. We would like to have two openam installations on the same machine.
    How we can implement this solution ? In order to do that how we can bypass the issue related to the configuration of .openamcfg folder that it contains the openam installation folder ?

    Thanks in advance

    #3755
     Victor Ake
    Participant

    Hi
    The .openamcfg directory would contain a file per each of your tomcat installations, each of the files will contain inside, the name of the directory where the configuration for such instance will be stored.

    So, as long as you do use different TCP ports for everything, it should be OK.

    Why do you want to do that, resource distribution?

    #3775
     Ayaz
    Participant

    Hi,

    If you want to put 2 different openam installation, you need to deploy 2 openam.war having different name like openamsp & openamidp in tomcat. After configuration, there will be 2 different openam configuartion folder in your home-directory for each war. And u will access each instance with different context path:
    http://localhost:8080/openamsp
    http://localhost:8080.openamidp

    Regards
    ~Ayaz

    #3776
     Ayaz
    Participant
    #3777
     Victor Ake
    Participant

    Hi, You must never use localhost as a name when installing OpenAM, pleas read: http://docs.forgerock.org/en/openam/12.0.0/install-guide/index/index.html

    Additionally, when installing N OpenAMs in the same system, you will have 1 .openamcfg directory with N files within the directory, each of the files will point to the location of your deployed openam war file (using the name of the file), and the content of the file is the location of the configuration folder for the instance.

    #3795
     Ayaz
    Participant

    Thanks Victor, you are correct.

    I just used “localhost” for explanation purpose only.

    Regards
    ~Ayaz

    #4046
     elena.digennaro
    Participant

    it works ! Thank you

    #14074
     Frotonis
    Participant

    Hi,

    i have already set configuration for two instances of OpenAM (version 13).

    when i have ready both of this instances one tell me that there is no configuration found. When i shutdown one instances everything is correct.

    Can somebody help me pls?

    thx a lot for answer

    #14127
     nikolaosinlight
    Participant

    See reply here: Two standalone instances on same Tomcat container

    https://forgerock.org/topic/two-standalone-instances-on-same-tomcat-container/

    –Nikolaos

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

©2022 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?