TPP Registration Failed due to missing TPP role

This topic contains 1 voice and has 0 replies.

  • Author
    Posts
  • #24276
     coco-dev 
    Participant

    Tried registering our TPP using SSA provided by OB sandbox directory. Got the following error:

    {
    “timestamp”: “2018-12-19T09:45:42.710Z”,
    “status”: 500,
    “error”: “Internal Server Error”,
    “message”: “No enum constant com.forgerock.openbanking.commons.model.tpp.Tpp.Type.CBPII”,
    “path”: “/open-banking/registerTPP”
    }

    It looks like a new open banking role CBPII (Something to do with Card Based Payments 2?) is not recognised by the mock ForgeRock ASPSP.

    Workaround likely to create a SSA without CBPII but haven’t tried as yet.

    Thanks

    Paul

    FYI SSA Extract:

    “software_roles”: [
    “AISP”,
    “PISP”,
    “CBPII”
    ],

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

©2019 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?