SSOADM in OpenAM 13 Gives Error com.sun.identity.cli.CLIException: com.sun.ident

Tagged: , ,

This topic has 0 replies, 1 voice, and was last updated 6 years, 2 months ago by sphsms.

  • Author
    Posts
  • #12048
     sphsms
    Participant

    When trying to run ssoadm to create policies, logs show up with the error :

    com.sun.identity.cli.CLIException: com.sun.identity.cli.realm.RealmCreatePolicy
    at com.sun.identity.cli.SubCommand.execute(SubCommand.java:298)
    at com.sun.identity.cli.CLIRequest.process(CLIRequest.java:217)
    at com.sun.identity.cli.CLIRequest.process(CLIRequest.java:139)
    at com.sun.identity.cli.CommandManager.serviceRequestQueue(CommandManager.java:576)
    at com.sun.identity.cli.CommandManager.<init>(CommandManager.java:173)
    at com.sun.identity.cli.CommandManager.main(CommandManager.java:150)

    com.sun.identity.cli.realm.RealmCreatePolicy

    I understand that as per OpenAM 13 documentation that two JVM properties for ssoadm need to be set :

    org.forgerock.openam.ssoadm.auth.indexType and
    org.forgerock.openam.ssoadm.auth.indexName. I am not sure where they need to be set and what they need to be set to. I checked under Top Level Realm > Authentication and it has modules, chains and settings showing up as options. Currently modules is set to ldapService.. is that something that requires change? Do I need to provide any other URL?

    I tried running ssoadm in debug mode and that is what the error showed up as. Way I ran that command is :

    ./ssoadm create-policies -e / -X mypolicies.xml -u amadmin -f /bits/forgerock/password.pwd -d

    Any help is appreciated.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

©2022 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?