Setting multiple J2EEAgents SSO

This topic has 1 reply, 2 voices, and was last updated 7 years, 8 months ago by Peter Major.

  • Author
    Posts
  • #3501
     k.satou
    Participant

    Hi, All.
    I set up two J2EE Agents, try to SSO.
    Look this figure.

    J2EE1–+
      OpenAM(SP)—OpenAM(IdP)
    J2EE2–+

    I log-ined OpenAM(IdP) via J2EE1. After that, I tried to log-in via J2EE2, but OpenAM(IdP)’s Login Screen was displayed again.
    How can I config multiple J2EEAgents SSO?

    Regard.

    • This topic was modified 7 years, 8 months ago by k.satou.
    • This topic was modified 7 years, 8 months ago by k.satou.
    #3519
     Peter Major
    Moderator

    How did you set it up exactly? Is the agent triggering an SP initiated SSO on the SP (or an IdP initiated SSO straight at the IdP)? Did you send a different <RequestedAuthnContext> in the second AuthnRequest that could have trigger a session upgrade at the IdP?
    In any case, you should check browser cookies and investigate if the cookie values gets lost or something (or if you have deployed both the SP and the IdP on the same cookie domain and they are using the cookie names as well, essentially overriding each other’s session cookies).

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

©2022 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?