sessionDomain Error: java.lang.NoSuchMethodException: org.eclipse.jetty.server

This topic has 3 replies, 2 voices, and was last updated 6 years, 8 months ago by Mark Craig.

  • Author
  • #6597

    Dear All,

    I am getting the below error when I configure OpenIG with Jetty 8 sessionDomain

    doc link:!/docs/openig/3.1.0/gateway-guide/chap-install#tomcat-cookie-domains

    Added at last of /path/to/jetty/etc/jetty.xml the following

    <Get name=”sessionHandler”>
    <Get name=”sessionManager”>
    <Set name=”sessionDomain”></Set>

    #java -Dopenig.base=/home/boss/.openig/ -jar start.jar

    I get the below error

    2015-12-18 09:30:37.281:WARN:oejx.XmlConfiguration:Config error at <Get name=”sessionHandler”><Get name=”sessionManager”><Set name=”sessionDomain”></Set></Get></Get> java.lang.NoSuchMethodException: org.eclipse.jetty.server.Server.getSessionHandler()
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(
    at java.lang.reflect.Method.invoke(
    at org.eclipse.jetty.start.Main.invokeMain(
    at org.eclipse.jetty.start.Main.start(
    at org.eclipse.jetty.start.Main.main(
    Caused by: java.lang.NoSuchMethodException: org.eclipse.jetty.server.Server.getSessionHandler()
    at java.lang.Class.getMethod(
    at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration.get(
    at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration.configure(
    at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration.configure(
    at org.eclipse.jetty.xml.XmlConfiguration.configure(
    at org.eclipse.jetty.xml.XmlConfiguration$
    at Method)
    at org.eclipse.jetty.xml.XmlConfiguration.main(
    … 7 more

    Usage: java -jar start.jar [options] [properties] [configs]
    java -jar start.jar –help # for more information

    Thanks & Regards
    Mehanathen N

     Mark Craig

    Hi Mehanathen N,

    I confirm that I’m seeing the same issue, and have logged against the docs.



    Thank U Mark. I was trying for past 2 days. Thanks

     Mark Craig

    It looks like maybe you need to set this in jetty/etc/webdefaults.xml:


Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

©2022 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?