search with LDAP filter ou=SelfWriteAttributes fails to return entries

This topic has 1 reply, 1 voice, and was last updated 4 years, 1 month ago by eshraiman.

  • Author
    Posts
  • #19997
     eshraiman
    Participant

    I am going through the exercise of adding a custom attribute to a user profile.
    I have AM and OpenDJ version 5.5 and follow steps as indicated in “AM Setup and Maintenance guide” chapter 3.3.1 “Customizing Profile Attributes” https://backstage.forgerock.com/docs/am/5.5/maintenance-guide/#customizing-data-stores

    I successfully completed Procedure 3.2 Update AMUser Service for the new attribute.
    Procedure 3.3 Update Identity repository for the new attribute had several glitches. caseIgnoreMatch is one word with no space in the middle and the whole of “EQUALITY caseIgnoreMatch ORDERING caseIgnoreOrderingMatch SUBSTR caseIgnoreSubstringsMatch” cased error from ldapmodify and I had to remove it for now. After that ldapmodify completed successfully.

    Now I can see my custom attributeType and objectClass under custom section in OpenDJ Control panel’s Manage Schema.

    Next Procedure 3.4 “Allow users update new attribute” does not work for me.
    Going to Control Panel ManageEntries and setting filter to “LDAP filter” with value “ou=selfWriteAttributes” returns no entries. Setting filter to ou=’*’ also returns no entries.

    As a different approach I added my new custom objectClass (auxiliary) to the People entry in OpenDJ control panel ManageEntries with the hope that the entries under will inherit it but I still don’t see my new custom attributeType when creating an entry.

    So the question stands: how to set selfWriteAttributes with the new custom one? and will I see it when creating/updating my user entries?

    Please advise.
    Eugenia.

    • This topic was modified 3 years, 11 months ago by Peter Major.
    #20044
     eshraiman
    Participant

    What BS is this and who is posting nonsense?

    I discovered that the step 3.4 “Allow users update new attribute” is not needed to change value of the newly added attribute.
    Unfortunately this only adds to confusion. If someone can comment but to the point please, would be appreciated.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

©2022 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?