This topic has 5 replies, 4 voices, and was last updated 5 years, 6 months ago by ytheva.

  • Author
    Posts
  • #11851
     faraon79
    Participant

    Hi,

    I’ve configured cross domain following administartion guide:

    https://forgerock.org/openam/doc/bootstrap/admin-guide/#enable-cdsso-jee-agent

    When try to open my applicatiom I am redirected to OpenAM login page but no in my realm.

    How can I solve it.

    Many thanks,
    Tomasz

    • This topic was modified 5 years, 11 months ago by Peter Major.
    #14558
     Thomas Liebeck
    Participant

    Same issue for me with apache web agent. Always redirected to top level realm for authentication. Don’t find a hint how to solve it. Openam 13.5

    Thomas

    #14571
     Peter Major
    Moderator

    You should change the CDSSO login URL in the agent profile to have the ?realm=/myrealm parameter in it.

    #14739
     ytheva
    Participant

    Same for me….

    I changed the OpenAM Login/Logout URL within the realm / agents / OpenAM servives to :

    http://example.com/openam/UI/Login?realm=/myrealm

    and also checked the agent.config on the Agent but nothing happends. Still a redirect to the top level like faraon79 and Thomas mentioned.

    Any ideas?

    OpenAM 13.5
    Apache WPA 4.0.1

    #14780
     Peter Major
    Moderator

    To modify the CDSSO login URL, you should modify the “CDSSO Servlet URL” setting under the SSO tab instead.

    #14785
     ytheva
    Participant

    Thanks Peter,

    works :)

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

©2022 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?