Problem with Assignments on Custom Managed Object

This topic has 0 replies, 1 voice, and was last updated 4 years, 9 months ago by chris-fry.

  • Author
    Posts
  • #20210
     chris-fry
    Participant

    Hi all,

    I’m trying to create a custom object in IDM v5.5 and map this to my directory, including assignments. The mapping is working for normal attributes, but not assignments.

    Here’s the steps I’ve taken:

  • Perform base install of IDM 5.5, using MySQL repository as per install guide
  • Create the custom object (employee)
  • Configure two way relationships between employee and role (similar to user/role)
  • Configure effectiveRoles and effectiveAssignments attributes for employee object (same as definition in user object)
  • Create a mapping between employee object and directory (default behaviour, Livesync off)
  • Create a test employee
  • Create a test role
  • Assign test role to test employee, confirm two way relationship
  • Create a test assignment that maps members of the test role to a custom, multi-valued attribute in the directory (orgMemberOf)
  • Run reconciliation
  • Result:

  • Test employee is replicated to directory
  • orgMemberOf is not populated
  • Other notes:

  • If I do the same thing with the default, user object in stead of the employee object, it works fine and orgMemberOf is populated
  • effectiveRoles and effectiveAssignments don’t appear to be working for the employee object (they return empty arrays).
  • What am I missing? Do I need to do something else to make effectiveRoles and effectiveAssignments work?

    Thanks,

    – Chris

    • This topic was modified 4 years, 9 months ago by chris-fry.
Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

©2022 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?