OpenDJ-3.0.0 Backup and Restore does not work in windows platform only

This topic contains 3 replies, has 3 voices, and was last updated by  Gentjan Kocaqi 1 week ago.

  • Author
    Posts
  • #25756
     Rohit Gaikwad 
    Participant

    Hi All,

    I’m getting PatternSyntaxException as below on windows operation system only while performing Restore operation on OpenDJ 3.0.0.

    Exception Message:
    [08/05/2019:15:31:59 +0530] category=TOOLS seq=0 severity=SEVERE msg=An unexpected error occurred while attempting to restore backup 20190508150753 from D:\Users\abc\Downloads\opendj\bak\config: PatternSyntaxException(Illegal/unsupported escape sequence near index 3

    D:\Users\abc\Downloads\opendj\config.save\d*
    ^)

    System configuration:
    1. OS: Windows 7 64 bit
    2. java version “1.8.0_152”

    Please find the below steps to reproduce the issue:

    1. Stop OpenDJ
    2. Open control-panel and take a full backup via Backup GUI
    (All Backends option is marked/checked and rest of the settings are default)
    3. Using Restore GUI do Verify Backup (This is successful)
    4. Click on OK & subsequently “Yes” buttons for complete restore of the Backup
    5. “Restore Complete” message is displayed but exception is printed in the details section. However, the backup is not successful.

    The backup file generated is suspicious as it contains some illegal characters for “dn: cn=File-Based Error Logger,cn=Loggers,cn=config” and “dn: cn=SHA-1,cn=Password Storage Schemes,cn=config”

    I would like to know that whether this is a known issue and If yes, whether it is fixed in any other version (Free/Paid version) of OpenDJ?

    Thanks,
    Rohit

    • This topic was modified 1 week, 6 days ago by  Peter Major.
    #25769
     Ludo 
    Moderator

    This doesn’t seem to be a known issue.
    This said, the Control-Panel has been deprecated and removed from the latest versions of OpenDJ/ForgeRock Directory Services. So in essence, the issue is resolved, but you will need to run backup/restore from the command line.

    #25773
     Rohit Gaikwad 
    Participant

    Thanks Ludo for your response. Today, I tried backup/restore using command line But, it failed with same error in windows.
    Below are the commands used:
    Backup:
    D:\abc\OpenDJ\server\bat>backup.bat -d D:\abc\OpenDJ\server\bak\bak5 –backUpAll –backupID 20190510093400

    Restore:
    D:\abc\OpenDJ\server\bat>restore.bat -d D:\abc\OpenDJ\server\bak\bak5\config –backupID 20190510093400 –noPropertiesFile

    Error:
    [10/05/2019:12:27:19 +0530] category=TOOLS seq=0 severity=SEVERE msg=An unexpected error occurred while attempting to restore backup 20190510093400 from D:\abc\OpenDJ\server\bak\bak5\config: PatternSyntaxException(Unknown character property name {t} near index 4
    D:\abc\OpenDJ\server\config.save\d*
    ^)

    The similar command do work fine in Linux platforms. I also tried executing the equivalent commands generated in GUI, However it failed again.

    Can you please check this issue of command line on windows for both OpenDJ 3.0.0 and paid versions to verify whether the issue do exists or not?

    Thanks,
    Rohit

    #25797
     Gentjan Kocaqi 
    Participant

    Here are my commands converted to Windows (I do make use of Linux)

    Backup:
    ./backup.bat --port 4444 --bindDN "cn=Directory Manager" --bindPassword password --backUpAll --backupDirectory D:\abc\OpenDJ\server\bak\ --start 0

    List backups (get the ID):
    ./restore --backupDirectory D:\abc\OpenDJ\server\bak\ --listBackups

    Restore:
    ./restore --port 4444 --bindDN "cn=Directory Manager" --bindPassword password --backupDirectory D:\abc\OpenDJ\server\bak\ --backupID 20190515093505Z

    How about to try these commands instead? What is the output?

    Since you are backing up all, how about if you try to restore let’s say SCHEMA instead of ALL or CONFIG and see if you get the same issue. I do believe that something is wrong in your OpenDJ instance on Windows (maybe corrupted?!).

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

©2019 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?