This topic has 2 replies, 2 voices, and was last updated 7 years, 4 months ago by k.satou.

  • Author
    Posts
  • #4883
     k.satou
    Participant

    Hi,All.

    I’m trying to tuning User data store(PostgreSQL) and OpenAM REST API.
    Right after create user using REST API, I search the user by REST API. But the user cannot be found.
    I refer to this page, I understood it is because RDB(PostgreSQL) don’t have “persistent search”.

    http://stackoverflow.com/questions/28476511/openam-rest-api-json-users-fields-ismemberof-attribute-does-not-show-updated-r

    So I set the parameter “com.iplanet.am.sdk.caching.enabled=false”. That went well.

    Actually, I do not want to disable the cach. What would be a another good way to do it?
    And, can RDB not really to persistent search?

    Please give me your help.
    Regard.

    #4916
     Peter Major
    Moderator

    There is no persistent search for databases, no. You should disable am.sdk.caching and enable sm.cache straight afterwards. But create+search shouldn’t be a cache related issue, searches aren’t (“quite”) cached, maybe your create never actually succeeded in the first place?

    #4919
     k.satou
    Participant

    Thank you, Peter.
    In fact in OpenAM admin console the user was created by the first REST command.
    I think the RDB has not been committed yet.
    Regards.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

©2022 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?