OAuth Authorization Grant flow fails with Technical Error

Tagged: 

This topic contains 1 reply, has 2 voices, and was last updated by  Gentjan Kocaqi 3 months, 4 weeks ago.

  • Author
    Posts
  • #25080
     Rick521 
    Participant

    Hi,

    I have been working on OAuth2 Authorization Grant Flow

    step1 . got the sso token
    step 2 while I use this curl it errors out in Technical Error where as it works fine in browser

    curl -v –request POST –header “Content-Type: application/x-www-form-urlencoded” –header “Cookie: custom-ccokie=${token}” “https://openam.example.com/auth/oauth2/authorize?realm=%2subrealm&client_id=ExampleClient&response_type=code&redirect_uri=https%3A%2F%2Ftest.example.com%2Ftest&scope=uid&save_consent=0&decision=Allow”

    can someone please explain or point to the right process I should use.

    Thanks,
    Rick

    #25116
     Gentjan Kocaqi 
    Participant

    Hey,

    That curl contains many typo errors. Fix them and try again providing more info about the error you are getting. Which version of AM are you working on and which is the page/url you are following to achieve this?

    Cheers

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

©2019 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?