Not able to see Users in Open-AM

This topic has 19 replies, 7 voices, and was last updated 5 years, 7 months ago by SaiTrinet.

  • Author
    Posts
  • #10487
     sharad.jash
    Participant

    I’m using Open-AM 13.0 added 700+ users Open-DJ.But I’m unable to see all users in Subjects.

    Is there anything more to be done?

    #10488
     Rajesh R
    Participant

    @sharad.jash have you configured that OpenDJ as the DataStore for the realm where you are expecting those users to show up as subjects? You need to go to DataStore and populate details about your OpenDJ instance for the users in the OpenDJ to show up in the subjects tab for that realm.

    #10489
     Rajesh R
    Participant

    See if the following screen-casts help

    Configuring OpenDJ as a DataStore for an OpenAM Realm

    #10491
     sharad.jash
    Participant

    Hi @Rajesh R …
    thanks for your reply…

    Yes I have configured Open-DJ as Datastore and also checked your video
    what I’m actually facing is I have 700+ users in which only 102 users are showing in Open-AM.

    Also,

    In your video I’m unable to understand this line “Lets confirm the realm has visibility of 2000 users in the external Open-DJ instance” at 5.25sec
    is there something to be configured for max number of users.

    • This reply was modified 6 years, 3 months ago by sharad.jash.
    #10493
     Bhargava.bada
    Participant

    Hi Sharad ,

    Follow below points it might solve your problem .

    1. Load schema when saved check box and save it . verify in subjects .

    2. verify your User configuration details .make sure you user search attributes and Naming attributes provided based on your OpenDJ configuration .

    Thanks
    Bhargava

    #10494
     sharad.jash
    Participant

    Hi Bhargava

    Thanks for your reply,

    1. I have checked the box to load the schema ,also verified subjects.
    2. User search attributes looks all fair as I’m able to get all 102 user of 700.

    ** I have checked a user is not showing in Subjects but using that user’s credentials I’m able to login in Open-AM.

    #10495
     Bhargava.bada
    Participant

    Hi Sharad,

    Apply user filter and check .the user might be there or some UI restrictions might be there for subjects screen .

    Thanks
    Bhargava

    #10498
     sharad.jash
    Participant

    Hi @Bhargava
    I applied all filter I can.
    Yes you are correct the user is present some kind of UI restriction is there.
    Do you have any idea how to remove this restriction ?

    #10500
     Scott Heger
    Participant

    It would help to understand why you need to see all these users in the Subjects tab. If just for validation that OpenAM has visibility into the users then you can do that via a Search as you have done. You really don’t want to use OpenAM as a means of managing user accounts unless you have no other option.

    #10520
     sharad.jash
    Participant

    Hi Scott
    I need to assign some privileges to some particular users and if the user is not visible in list then it would be hard to figure out which user has what access.
    Also, I’m not able to understand why it is showing only 100 users.Is there a some kind of bug ?

    #10521
     Bhargava.bada
    Participant

    Hi Sharad,

    try to use the User Filter in subjects tab and see that particular user is displaying or not .
    if it is working just go one by one .

    Thanks
    Bhargava

    #10526
     sharad.jash
    Participant

    Hi @bhargava-bada

    I have tried to use the subject filter but I’m still in the same position.

    User is not seen in list but able to log-in in AM.

    • This reply was modified 6 years, 3 months ago by sharad.jash.
    • This reply was modified 6 years, 3 months ago by sharad.jash.
    #10567
     wshen
    Participant

    Hi, @sharad.jash

    I think the configuration -> console -> administration -> realm attributes -> Maximum Results Returned from Search, might be the setting you looking for. However, increase the value to 2000 will have impact on console performance.

    #10569
     sharad.jash
    Participant

    Hi @wshen

    I’m still not able to see all users.

    #10584
     sharad.jash
    Participant

    Thanks @wshen @bhargava-bada @raheshr @scott and to all memebers

    Issue is resolved now.

Viewing 15 posts - 1 through 15 (of 20 total)

You must be logged in to reply to this topic.

©2022 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?