J2EE Agent User Data Cache is not refreshing

Tagged: , , , ,

This topic has 6 replies, 4 voices, and was last updated 6 years, 10 months ago by Peter Major.

  • Author
    Posts
  • #4174
     mmdave
    Participant

    We have our web agent working correctly, with it refreshing the user data if anything changes in Active Directory. The J2EE Agent however doesn’t refresh the user data if it changes.

    I’ve read tons of documentation and made a lot of changes, to utilize polling and have it set for 3 minutes – and even disabling the caches doesn’t refresh it either. We’ve disabled notifications so the polling options should kick in.

    Does anyone have any experience on this front on the specific config changes for the J2EE agent that will actually work?
    Thank you!

    #4208
     Rogério Rondini
    Participant

    Hi,

    Where user data is being changed ? From OpenAM UI or direct in AD ?

    Maybe neither OpenAM Server has been notified about user data changes if changes are performed by external application direct on AD, i.e, OpenAM DataStore keep caching old data.

    DataStore update user data cache by the persistent search mechanism. Maybe you need to check if AD is able to works with psearch and if DataStore is right configured to do that.

    Abs.

    #4209
     mmdave
    Participant

    We already have it working for the web agent side, the changes aren’t working for the j2ee side. Changes are being made through AD. Before we were able to get the user data cache to refresh via web agent, we could use the openAM api to check the DataStore user data, and at first the roles didn’t match up. The web agent was getting the correct information from AD after it had been changed, but it didn’t refresh the DataStore. We made changes, and it worked but it’s not working for the J2EE agent. We have to refresh Jetty for the data to refresh for the J2EE side.

    #4210
     Rogério Rondini
    Participant

    Ok.. maybe has a bug.

    Maybe you can test other versions/jee servers (in tomcat for example)… otherwise, just a ticket to support.

    #4212
     mmdave
    Participant

    These are my current settings:
    I’ve changed a few things to see if it would effect a change but nothing has worked for the J2EE side. If someone would have some insight that would be great. Ideally we’d like to disable notifications and utilize polling.

    Configuration > Server and Sites > Site > Advanced
    current
    com.iplanet.am.sdk.caching.enabled FALSE
    com.iplanet.am.idm.caching.enabled TRUE
    com.sun.identity.idm.cache.entry.expire.enabled TRUE
    com.sun.identity.sm.cacheTime 0
    com.iplanet.am.session.client.polling.enable TRUE
    com.iplanet.am.session.client.polling.period 5
    com.iplanet.am.sdk.remote.pollingTime 5
    com.sun.identity.sm.cache.enabled TRUE

    Top Realm > Agents > J2EE Agent > openAM Service
    current
    com.sun.identity.sm.notification.enabled FALSE
    com.iplanet.am.sdk.remote.pollingTime 5
    com.sun.identity.sm.cacheTime 3
    com.iplanet.am.sdk.remote.pollingTime 3
    com.sun.identity.agents.notification.enabled FALSE
    com.sun.identity.idm.remote.notification.enabled FALSE
    com.sun.identity.agents.polling.interval 3
    com.iplanet.am.session.client.polling.enable FALSE
    com.iplanet.am.session.client.polling.period 180

    #6289
     larseirik
    Participant

    Hi, I have seem to have the same issue. Upon Federating i try to update my user, but i need to restart my j2ee agent (tomcat) to get the updated data in my profile listing.

    Did you find a fix?

    #6321
     Peter Major
    Moderator

    If you are both using AD, then maybe you are running into OPENAM-3693

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

©2022 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?