Issues Getting Started With OpenAM

This topic has 5 replies, 4 voices, and was last updated 5 years ago by pooja14.

  • Author
    Posts
  • #15634
     jmcdowell
    Participant

    Hello,

    I am following the getting started guide (https://backstage.forgerock.com/docs/openam/13.5/getting-started) for openAM 13.5 to get an instance of openAM 13.0 up and running. For the most part it seems like this guide is similar enough that it works to get started in 13.0 as well.

    However, I am running into an issue getting the Web Agent to install. I have followed the guide and have Apache httpd Server 2.4 running at http://www.example.com:8000. I also have OpenAM running at openam.example.com:8080/openam on Tomcat 7. I have setup the policy, and policy set to allow all authenitcated users to http://www.example.com:8000/* as covered in the startup guide, and I have also setup the new web agent inside of OpenAM called WebAgent.

    I then run the installer while the httpd server is not running and the Tomcat server with OpenAM are running. I am on windows server 2012 R2 so I have the Appache 2.4 windows 64 bit web agent installer.

    My installation Parameters are:

    OpenAM URL: http://openam.example.com:8080/openam
    Agent URL: http://www.example.com:8000
    Agent Profile name: WebAgent
    Agent realm/organization name: “Top Level Realm”
    Agent Profile password source: C:\Users\Administrator\.pwd.txt

    The .pwd.txt file is set to read only and has just the string “password” as its contents.

    I then approve this configuration and attempt to run the installation. My installation then fails and I have the following output in the log file where it appears I have a connection timeout. Does anyone know how to resolve this issue?

    2017-01-31 13:33:00 am_url_validate(): status is set to 0 (success)
    2017-01-31 13:33:00 am_url_validate(): response status code: 302
    2017-01-31 13:36:06 Agent URL http://www.example.com:8000
    2017-01-31 13:36:10 Agent Profile name WebAgent
    2017-01-31 13:36:17 Agent realm/organization name “Top Level Realm”
    2017-01-31 13:36:39 Agent password file C:\Users\Administrator\.pwd.txt
    2017-01-31 13:36:39 agent password file C:\Users\Administrator\.pwd.txt opened successfully
    2017-01-31 13:40:13 validating configuration parameters…
    2017-01-31 13:40:13 send_authcontext_request(): sending 491 bytes
    2017-01-31 13:40:13 send_authcontext_request(): response status code: 200
    <?xml version=”1.0″ encoding=”UTF-8″ standalone=”yes”?>
    <ResponseSet vers=”1.0″ svcid=”auth” reqid=”0″>
    <Response><![CDATA[<?xml version=”1.0″ encoding=”UTF-8″?>
    <AuthContext version=”1.0″><Response authIdentifier=”null”><Exception ></Exception></Response></AuthContext>]]></Response>
    </ResponseSet>
    2017-01-31 13:40:13 create_cookie_header(): request header: Cookie: JSESSIONID=00F6A520AB78D6B88319927197A9E931

    2017-01-31 13:40:13 send_login_request(): sending 999 bytes
    2017-01-31 13:40:13 send_login_request(): authenticate response status code: 200
    <?xml version=”1.0″ encoding=”UTF-8″ standalone=”yes”?>
    <ResponseSet vers=”1.0″ svcid=”auth” reqid=”0″>
    <Response><![CDATA[<?xml version=”1.0″ encoding=”UTF-8″?>
    <AuthContext version=”1.0″><Response authIdentifier=”null”><Exception message=”Session has timed out” errorCode=”110″ templateName=”session_timeout.jsp”></Exception></Response></AuthContext>]]></Response>
    <Response><![CDATA[<?xml version=”1.0″ encoding=”UTF-8″?>
    <AuthContext version=”1.0″><Response authIdentifier=”null”><Exception message=”Session has timed out” errorCode=”110″ templateName=”session_timeout.jsp”></Exception></Response></AuthContext>]]></Response>
    </ResponseSet>
    2017-01-31 13:40:13 am_agent_login(): closing connection after failure
    2017-01-31 13:40:13 error validating OpenAM agent configuration
    2017-01-31 13:40:13 installation error
    2017-01-31 13:40:13 installation exit

    • This topic was modified 5 years, 6 months ago by jmcdowell.
    #15637
     Rajesh R
    Participant

    @jmcdowell Have you set the password in ‘WebAgent’ profile in OpenAM to the one that you’ve used in the file C:\Users\Administrator\.pwd.txt ?

    Setting the debug log to ‘message’ level might help to get a more clear picture on what could be wrong.

    #15644
     subi
    Participant

    @jmcdowell – I would use the ‘/’ value for the Top Level Ream (instead of Top Level Realm) in the WebAgent installer screen

    Pl try and let me know.

    #15645
     jmcdowell
    Participant

    Thank You! Subi that fixed it. I missed the part of the prompt that had’/’ as the option for the realm name.

    #18194
     pooja14
    Participant

    I have facing same issue even i set the password in Webagent profile on OpenAM GUI and also realm set as “/”
    2017-07-19 11:23:22 send_authcontext_request(): sending 472 bytes to http://172.30.66.128:8080/OpenAM/authservice
    2017-07-19 11:23:22 send_authcontext_request(): response status code: 200
    <?xml version=”1.0″ encoding=”UTF-8″ standalone=”yes”?>
    <ResponseSet vers=”1.0″ svcid=”auth” reqid=”0″>
    <Response><![CDATA[<?xml version=”1.0″ encoding=”UTF-8″?>
    <AuthContext version=”1.0″><Response authIdentifier=”null”><Exception ></Exception></Response></AuthContext>]]></Response>
    </ResponseSet>
    2017-07-19 11:23:22 create_cookie_header(): request header: Cookie: JSESSIONID=6324D1D67A35B9295DB87F5312504BD1.node2^M

    2017-07-19 11:23:22 send_login_request(): sending 997 bytes to http://172.30.66.128:8080/OpenAM/authservice
    2017-07-19 11:23:22 send_login_request(): authenticate response status code: 200
    <?xml version=”1.0″ encoding=”UTF-8″ standalone=”yes”?>
    <ResponseSet vers=”1.0″ svcid=”auth” reqid=”0″>
    <Response><![CDATA[<?xml version=”1.0″ encoding=”UTF-8″?>
    <AuthContext version=”1.0″><Response authIdentifier=”null”><Exception message=”Session has timed out” errorCode=”110″ templateName=”session_timeout.jsp”></Exception></Response></AuthContext>]]></Response>
    <Response><![CDATA[<?xml version=”1.0″ encoding=”UTF-8″?>
    <AuthContext version=”1.0″><Response authIdentifier=”null”><Exception message=”Session has timed out” errorCode=”110″ templateName=”session_timeout.jsp”></Exception></Response></AuthContext>]]></Response>
    </ResponseSet>
    2017-07-19 11:23:22 am_agent_login(): closing connection after failure

    Also when i copy the same uRL “http://172.30.66.128:8080/OpenAM/authservice&#8221; in browser, output is displayed as “OpenSSO”. One more query i have while installing policyagent it ask one parameter as:
    Existing OpenSSO.properties file , i ingnored it and did further installation. but getting the same issue.

    Please have a look at this.

    #18315
     pooja14
    Participant

    hello guys,

    Any update on this?
    Please help me out for resolving the issue mentioned above.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

©2022 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?