This topic has 0 replies, 1 voice, and was last updated 4 years, 3 months ago by aniru2dh.

  • Author
    Posts
  • #21749
     aniru2dh
    Participant

    Hi All,

    I am currently doing a poc and as part of that enabled user self services available in openam

    I have declared mail attribute as “Protected Update attributes” under profile management tab. Whenever I try to update the security questions it throws an error on the screen and the same is recorded in logs. But the update is successful, when I login again with the same account I could see the updated security questions.

    error:
    ERROR: IdentityResource.updateInstance() :: Cannot UPDATE resourceId=sample123
    org.forgerock.json.resource.BadRequestException: Must provide a valid confirmation password to change protected attribute (mail) from ‘[email protected]’ to ”

    But when I change the attribute from mail to userPassword or any other attribute it doesn’t throw any error and updates successfully. Is this some kind of bug in the product.

    Thanks,
    Anirudh.

Viewing 1 post (of 1 total)

You must be logged in to reply to this topic.

©2022 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?