Identity Gateway – Replay route example only works for user “demo”

This topic has 3 replies, 2 voices, and was last updated 1 week, 3 days ago by violette.

  • Author
    Posts
  • #28672
     deevodavis
    Participant

    I’ve managed to walk through the instructions here : https://backstage.forgerock.com/docs/ig/7.1/gateway-guide/credentials-am.html that describe how to setup Identity Gateway to redirect an unauthenticated user through AM’s login page and then back to the sample app.

    It all works if I use the standard “demo” / “Cha4ng31t” username and password.

    If I use another identity defined within AM e.g. “myuser” / “correctpassword” then it succeeds on the Authentication, but when it redirects me to the IG Sample App I get a blank page with just the word “Forbidden” as an error message.

    I know it’s authenticating OK with AM because if I use the wrong password for the other user e.g. “myuser” / “wrongpassword” it fails on authentication and shows me an error as such as a banner. If I disable the “demo” user it tells me the user is not active, and when I reactivate it then it all works OK again.

    So, my question is – is the sample app setup only to use the “demo” user or is there some specific configuration I need to apply for the other users to allow them to login as well?

    • This topic was modified 2 weeks, 2 days ago by deevodavis.
    • This topic was modified 2 weeks, 2 days ago by deevodavis.
    • This topic was modified 2 weeks, 2 days ago by deevodavis.
    #28676
     violette
    Participant

    Hi deevodavis,

    This is a bug within the Sample Application. Could you raise a JIRA in https://bugster.forgerock.org/jira/projects/OPENIG/issues ?
    The documentation is correct and it should work with any user/password.
    Thanks,

    #28681
     deevodavis
    Participant

    Hi Violette. It seems that I need a JIRA login to raise an issue, something I don’t have and in order to login an Administrator needs to provide one.

    #28687
     violette
    Participant

    Hi deevodavis,
    It seems that the JIRA is no longer available for community. You should be able to open a ticket from support if you are a customer.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

©2021 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?