Check OAUTH2 Session – response_type=none error

This topic contains 2 replies, has 2 voices, and was last updated by  Andrew 4 months, 3 weeks ago.

  • Author
    Posts
  • #25988
     Andrew 
    Participant

    Hi There,

    As per the manual (https://backstage.forgerock.com/docs/am/6.5/oidc1-guide/#session_management_state) you use the authorize endpoint with a response_type=none to obtain current session state.

    I’ve been trying to get this to work but continue to get error “unsupported_response_type”

    error_description=Response%20type%20is%20not%20supported.&error=unsupported_response_type

    As per the instructions, on the OAUTH2 client I have added “none” to the response types. The docs also mentions “the OAuth 2.0/OpenID provider must be configured for Session Management”. Any idea what this specific configuration is so i can check its enabled.

    Any assistance in being able to check, given an id_token, whether a user’s session is still active.

    This is the GET request I’m making.
    curl -X GET \
    ‘http://XXX/openam/oauth2/realms/root/realms/CIAM/authorize?response_type=none&client_id=aem&redirect_uri=http://YYY/authenticated.html&prompt=none&id_token_hint=eyJ0eXAiOiJKV1QiLCJraWQiOiJ3VTNpZklJYUxPVUFSZVJCL0ZHNmVNMVAxUU09IiwiYWxnIjoiUlMyNTYifQ.eyJhdF9oYXNoIjoic2gzLTdNcGpyUzFzVXY5dW5WaXpwZyIsInN1YiI6ImRlbW8iLCJhdWRpdFRyYWNraW5nSWQiOiI5ZGY5YTljMS03OTg3LTRjNWEtODJjOC1hYjFjMWI1OWRhN2EtOTU1MTk0IiwiaXNzIjoiaHR0cDovL2VjMi0zLTEwNS0xNDgtMTA5LmFwLXNvdXRoZWFzdC0yLmNvbXB1dGUuYW1hem9uYXdzLmNvbTo4MDgwL29wZW5hbS9vYXV0aDIvcmVhbG1zL3Jvb3QvcmVhbG1zL0NJQU0iLCJ0b2tlbk5hbWUiOiJpZF90b2tlbiIsImdpdmVuX25hbWUiOiJGaXJzdF9OYW1lIiwicHNldWRvbnltIjoiV2xkK25YaklPZ0syS0xQTTFoRCt1R0l4NjdhaS9zUjVQdC83SDI0R3dDQVd2cWhiVXZIU2lBNEVodlJPVWpYeSIsImF1ZCI6ImFlbSIsImNfaGFzaCI6ImpEc2Nub196ajlCcHVSZk9faXpIVmciLCJhY3IiOiIwIiwib3JnLmZvcmdlcm9jay5vcGVuaWRjb25uZWN0Lm9wcyI6InBWLWhZVFVJRzJFWWkxSEtZbDdtcGlFSG12YyIsInNfaGFzaCI6ImJLRTlVc3B3eUlQZzhMc1FIa0phaVEiLCJhenAiOiJhZW0iLCJhdXRoX3RpbWUiOjE1NjE1MjcxNTYsIm5hbWUiOiJGaXJzdF9OYW1lIExhc3RfTmFtZSIsInJlYWxtIjoiL0NJQU0iLCJmcl9pZCI6IjFkMWE1NzE3LTZiYjEtNDRjMC1hMzQwLTY2YmY5NDA4MTA4ZCIsImV4cCI6MTU2MTUzMDc2NCwidG9rZW5UeXBlIjoiSldUVG9rZW4iLCJmYW1pbHlfbmFtZSI6Ikxhc3RfTmFtZSIsImlhdCI6MTU2MTUyNzE2NH0.EMXd1tYJACqubgRdmJ1GvfGHR5Kvq3S6ZEaZe1oj4IHGp8OXnGu3ktaYl-QyH3aJ9xDIsBrE6P0bPvSzmKZ4z-AB5Dz96UqXpf6NNXShvkbg6KT-5lMkTwk77_sarmTshMg66b9_Y7UDKC27Q1pXFCiu84gQjgIWDb7SBhEaoKTlJZ4MXO-heZZz7wsM4wvfJlnRHqGdf-zP7-c9BFs8MYsmet42xweXJ9DHB0W39gKfe1RRxCIAhv86CcABM9qKztGlWrRl5H3EvrqYoUg369Me17YQxHaDtTJBqGtPMR6EKDudaDvM1kspoTKZMr1ZK0j-h4hO_–8QCrUzvFCTQ’ \
    -H ‘Accept: */*’ \
    -H ‘Cache-Control: no-cache’ \
    -H ‘Connection: keep-alive’ \
    -H ‘Content-Type: application/x-www-form-urlencoded’ \
    -H ‘Cookie: iPlanetDirectoryPro=mibuvLsUHFZ6pUBTCrPmZscXm60.*AAJTSQACMDEAAlNLABxqcGhCNXdad0I1TkVqWjJXL05pQkNmZHZwcjA9AAR0eXBlAANDVFMAAlMxAAA.*,iPlanetDirectoryPro=mibuvLsUHFZ6pUBTCrPmZscXm60.*AAJTSQACMDEAAlNLABxqcGhCNXdad0I1TkVqWjJXL05pQkNmZHZwcjA9AAR0eXBlAANDVFMAAlMxAAA.*; amlbcookie=01; iPlanetDirectoryPro=mibuvLsUHFZ6pUBTCrPmZscXm60.*AAJTSQACMDEAAlNLABxqcGhCNXdad0I1TkVqWjJXL05pQkNmZHZwcjA9AAR0eXBlAANDVFMAAlMxAAA.*’ \
    -H ‘Host: http://XXX:8080‘ \
    -H ‘User-Agent: PostmanRuntime/7.15.0’ \
    -H ‘accept-encoding: gzip, deflate’ \
    -H ‘cache-control: no-cache’ \
    -H ‘content-length: 8’

    #26062
     Peter Major 
    Moderator

    Which AM version are you using? https://bugster.forgerock.org/jira/browse/OPENAM-14166 was only backported to 6.5.2

    #26075
     Andrew 
    Participant

    I’m using 6.5.1.

    I’ll try with 6.5.2.

    Thanks Peter

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

©2019 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?