Authentication issues in AM 5.5

This topic contains 2 replies, has 2 voices, and was last updated by  mohammedanask 5 months, 1 week ago.

  • Author
    Posts
  • #20500
     mohammedanask 
    Participant

    We’re trying to upgrade AM from 5.1 to 5.5 and we are facing issues with authenticating a user that exists in a subrealm. The AM subrealm is configured to connect to an external OpenDJ server which has the user’s information. I was able to authenticate the user in the last version using “/openam/json/authenticate?realm=<mysubrealm>” URL suffix. I tried this URL suffix in the new version but it doesn’t work. I have also tried this URL suffix: “/openam/json/realms/root/realms/<mysubrealm>/authenticate” based on the documentation ***. Both URLs suffix give a 401 error. I also tried authenticating directly through the website on a browser using this URL suffix: “/openam/XUI/?realm=/<mysubrealm>#login/”

    I can view the user in AM subjects under my subrealm and I have also verified the password in OpenDJ.

    Could you please help solve this issue. Any help will be appreciated.

    #20514
     Peter Major 
    Moderator

    You should check the Authentication debug logs for clues as to why the authentication is failing. The URLs you’ve been using look correct to me.

    #20521
     mohammedanask 
    Participant

    Hi Peter,

    Thanks for responding. I was able to activate the logs and see the Authentication log file. I wasn’t able to debug why these exceptions occur: https://pastebin.com/b7JR4aGq
    If you can help me out that would be great.

    Thanks

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

©2018 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?