Authentication fail with Proxy

This topic has 1 reply, 2 voices, and was last updated 5 years, 9 months ago by bthalmayr.

  • Author
  • #15655


    I have a Problem with my Installation on a Oracle VM. It runs with CentOS 7 on localhost.
    I installed OpenDJ as external store successfully and OpenAm on Tomcat 7 with the address I configured tomcat to use a Proxy Server by putting the command JAVA_OPTS="-DproxySet=true -DproxyHost=***.***.*** -DproxyPort=*** -DnonProxyHosts='*' $JAVA_OPTS"
    in . I thought that was all to to because in many Websites they say so but it doesn’t seems that way.

    If i set the debug level for Authentication in Debug.jsp at the highest level I get this: (really long)

    Sorry that there are some lines in German. My System is in English and my entire configuration but it keeps being in German.

    The Message

    com.sun.identity.authentication.spi.AuthLoginException: Authentication failed with an Input/Output exception while trying to get content

    tells me that something is wrong with my Proxy settings am i right?

    I have set the same Proxy in System Settings and in Firefox. I don’t know anymore what to do because i tried nearly everything that i found on the internet by searching this error.

    Thanks in advance for your help and a good day,


    • This topic was modified 5 years, 10 months ago by Dafugh.

    Hi Jonathan, have you seen the root cause?

    Caused by:
        at Source)
        at Source)
        at Source)
        at Source)
        at Source)
        at Source)
        at Source)
        at<init>(Unknown Source)
        at Source)
        at Source)
        at Source)
        at Source)
        at Source)
        at Source)
        at org.forgerock.openam.authentication.modules.oauth2.OAuth.getContentStreamByGET(
        ... 88 more

    You can also spot this means the configured HTTP forward-proxy is not used, see (referencing latest JDK docs, but it’s the same for JDK 7) , section 2.2. HTTPS

    -Dhttps.proxyHost=.... -Dhttps.proxyPort

    When the target URL has scheme ‘https’, the client must use the ‘connect’-protocol to use an HTTP forward-proxy.


Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

©2022 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?