Amster failed to import config file

This topic has 1 reply, 2 voices, and was last updated 4 years, 7 months ago by Tasos Kampas.

  • Author
    Posts
  • #20804
     datta
    Participant

    Hi All,
    Trying export and then import on same box. While importing config files getting below errors

    Failed to import /tmp/amsterExport/realms/root-xyz/Authentication.json : 400 Bad Request: Data validation failed for the attribute, iplanet-am-auth-admin-auth-module
    Failed to import /tmp/amsterExport/realms/root-xyz/Authentication.json : 400 Bad Request: Data validation failed for the attribute, iplanet-am-auth-admin-auth-module
    Failed to import /tmp/amsterExport/realms/root-xyz/Authentication.json : 400 Bad Request: Data validation failed for the attribute, iplanet-am-auth-admin-auth-module

    Thanks,

    #20966
     Tasos Kampas
    Participant

    Hi Datta,

    The attribute iplanet-am-auth-admin-auth-module refers to the following input in XUI: [Realm Name]/Authentication/Settings/Administrator Authentication Configuration. You can via REST as well:

    curl -X GET \
      http://openam.example.com:18080/openam/json/realms/root/realms/[Realm Name]/realm-config/authentication \
      -H 'Cache-Control: no-cache' \
      -H 'Content-Type: application/json' \
      -H 'iPlanetDirectoryPro: [SSOToken here]'

    I would assume you deleted the default ldapService chain and you didn’t update this setting. Use a valid chain for this field and then run the Amster export again.

    Thanks,
    Tasos

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

©2022 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?