This topic has 3 replies, 3 voices, and was last updated 4 years, 7 months ago by jochenr.

  • Author
    Posts
  • #20243
     sbsivertsen
    Participant

    Hi,

    I’m trying to install the latest OpenAM but when OpenAM starts I only get the error i debug log and the AM Console won’t load:

    ==> /opt/openam/sso/debug/IdRepo <==
    amSDK:12/21/2017 03:06:16:553 PM CET: Thread[localhost-startStop-1,5,main]: TransactionId[fc8a0003-86cc-49dc-ac5d-2d1766f887e2-0]
    ERROR: JCEEncryption:: Unsupported version: -62

    I have tried this “work around” (https://bugster.forgerock.org/jira/browse/OPENAM-12110) but it dosen’t work for me, not sure I’m doing it right thoug.
    So at this point I’m stuck.

    Anyone seen this before?

    Best Regards
    Stig Sivertsen

    #20244
     Gentjan Kocaqi
    Participant

    Could you share some more info about your environment. Info like OS used, JDK version, Application Server version and so on…

    #20245
     sbsivertsen
    Participant

    OS: CentOS 7

    JAVA:
    [[email protected] ~]# java -version
    openjdk version “1.8.0_151”
    OpenJDK Runtime Environment (build 1.8.0_151-b12)
    OpenJDK 64-Bit Server VM (build 25.151-b12, mixed mode)
    [[email protected] ~]#

    Tomcat:
    Apache Tomcat 8.5

    #20258
     jochenr
    Participant

    Hi,

    I think it’s related to the cookie domain that configured as mentioned here: https://backstage.forgerock.com/knowledge/kb/article/a73027813

    From Tomcat 8.5 the cookie domain cannot contain a leading .(dot) so .example.com will fail and example.com will work.

    Hope this solve the issue.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

©2022 ForgeRock - we provide an identity and access platform to secure every online relationship for the enterprise market, educational sector and even entire countries. Click to view our privacy policy and terms of use.

Log in with your credentials

Forgot your details?