Forum Replies Created

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #14883

    @Rajesh R

    I need to setup my website login process using openam, so , try to install openam follw this document.https://backstage.forgerock.com/docs/openam/13/getting-started#software-setup and its working fine.

    But, I have used nginx has a web server in production. But, no web policy agent have nginx
    webserver in official. only for apache and microsoft lls. so, i follow this link to setup nginx webagent, but i got issue.

    tool ==> https://github.com/hamano/nginx-mod-am
    issue ==> https://github.com/hamano/nginx-mod-am/issues/12

    As Per Your Suggestion, we could use OpenIG as an alternative, in which case the requests from clients go to OpenIG, OpenIG will redirect the request to OpenAM, OpenAM will ask user for credentials and then the control is passed to OpenIG to redirect the user request to application.

    I follow your video tutorials, https://forgerock.org/2015/08/forgerock-openig-getting-credentials-from-forgerock-openam/, But You use J2EE Policy web-agent. J2EE policy agent not suitable for web application reference: https://docs.oracle.com/cd/E19575-01/820-5816/gakwi/index.html

    I follow @Rogerio Rondini answer, https://forgerock.org/topic/can-i-use-nginx-instead-of-apache-webserver-in-openam/#post-14841 , they suggest to use openIG but, openIG way also used policy agent. https://backstage.forgerock.com/docs/openig/4.5/gateway-guide#capture-replay-flow

    my questions are:

    1. without web policy agent, can i authenticate a website using openam?
    2. policy agent vs openIG?
    3. can i use only openIG + openAm to website authenticate without using web policy agent?

    #14875

    I have Tested this tool. But, i got issue while install,

    issue: https://github.com/hamano/nginx-mod-am/issues/12

    Suggest me How to fix this.

    #14762

    Sorry, Now i have fixed this issue, i have some miss configured in opanam mysql datasource. Now, its works fine.

    #14760

    yes, i configured a Policy in OpenAM, i created new Policy set(my policy set) not using iPlanetAMWebAgentService with in policy set I have configured a Policy in OpenAM like what you suggested.

    #14759

    Hell [email protected],

    Thanks for your reply man, I have fixed this issue, i had miss configuration in openam data source.

    #14748

    I have fixed AMUncaughtException, i missed to add some tables columns that is what this occur, i fixed this issue, But, after

    goto -> “Subject”->”User” tab, press “New” button and configured user details, than, click create a user, it throw error.

    follow this link i post a question to forum https://forgerock.org/topic/datasource-change-issue/

    #14726

    Hello [email protected],

    i have configured, as per you suggestion, after remove In the “data store” tab, delete existing “embedded” the OpenDJ.

    I open openam(13.0) console click subject its throw exception, AMUncaughtException

    url ==> openam.test.mobi:8080/openam/base/AMUncaughtException

    error mag ==> An error occurred while processing this request. Contact your administrator.

    what i did:

    1. create database,
    2. grant privillage,
    3. create table,
    4. copy mysql-connect.jar to /tomcat/webapps/openam/WEB-INF/lib,
    5. restart the tomcat
    6. Login to OpenAM Management Console.

    7. “Access Control” -> “/(Top level realm)”->”Datastore”

    8. Press the “New” button. In “Step 1/2 Select the type of data store”, you set the following. After setting, you press the “Next”.

    Name: mysql
    Type: database repository(Early Access)

    9. In “Step 2/2 the new data store in a database repository(Early Access)”, perform the MySQL settings. After setting you press the “End”.

    Connection Type: Connection is retrieved via programmatic connection
    Database DataSource Name: java:comp/env/jdbc/user_db
    JDBC Driver URL: jdbc:mysql://127.0.0.1:3306/user_db
    Password for Connecting to Database: xxxx
    Database User Table Name: auth_users

    10. In the “data store” tab, delete existing “embedded” the OpenDJ.

    goto, openam console, click subject its throw exception

    Suggest me, How to can fix this issue.

    #14720

    Hello Gbadamosi,

    Thanks, After I install, apache webserver using httpd.tar.gz file , its working fine, before i install using command(apt-get install apache2), some one suggest me , you need to install apache 2 usign tar.gz file, after that, i fixed.

    #14648

    I have checked tomcat logs,

    I got below error in localhost.2016-12-05.log

    05-Dec-2016 06:56:04.626 SEVERE [localhost-startStop-2] org.apache.catalina.core.ApplicationFilterConfig.release Failed to destroy the filter named [X
    UIFilter] of type [org.forgerock.openam.xui.XUIFilter]
    java.lang.ExceptionInInitializerError
    at org.forgerock.openam.xui.XUIState.destroy(XUIState.java:109)
    at org.forgerock.openam.xui.XUIFilter.destroy(XUIFilter.java:139)
    at org.apache.catalina.core.ApplicationFilterConfig.release(ApplicationFilterConfig.java:312)
    at org.apache.catalina.core.StandardContext.filterStop(StandardContext.java:4733)
    at org.apache.catalina.core.StandardContext.stopInternal(StandardContext.java:5528)
    at org.apache.catalina.util.LifecycleBase.stop(LifecycleBase.java:221)
    at org.apache.catalina.core.ContainerBase$StopChild.call(ContainerBase.java:1423)
    at org.apache.catalina.core.ContainerBase$StopChild.call(ContainerBase.java:1412)
    at java.util.concurrent.FutureTask.run(FutureTask.java:266)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)
    at java.lang.Thread.run(Thread.java:745)
    Caused by: com.sun.identity.security.AMSecurityPropertiesException: AdminTokenAction: FATAL ERROR: Cannot obtain Application SSO token.
    at com.sun.identity.security.AdminTokenAction.run(AdminTokenAction.java:268)
    at com.sun.identity.security.AdminTokenAction.run(AdminTokenAction.java:74)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.forgerock.openam.xui.XUIState$XUIMode.<init>(XUIState.java:50)
    at org.forge

    what is the error. why its occur, suggest me How to solve this,

    Note: you mentioned install.log, where this log file store in openam docker machine and if its there . how can I enable logging in openam.

Viewing 9 posts - 1 through 9 (of 9 total)